<!doctype html>
<html lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="https://gmpg.org/xfn/11">
<title>Trinidad Tribune</title>
<style type="text/css">
                    .twp-site-branding .twp-logo,
            .twp-site-branding.twp-overlay .twp-logo,
            .twp-site-branding .twp-logo a,
            .twp-site-branding .twp-logo a:visited
            .twp-site-branding.twp-overlay .twp-logo a,
            .twp-site-branding.twp-overlay .twp-logo a:visited{
                color: #dd1a1a;
            }
                </style>

<meta name="description" content="Trinidad &amp; Tobago News" />
<meta name="keywords" content="#cruisenews,#travelnews,#royalcaribbean,#caribbeantravel,#caribbeancruisenews,#bermuda" />
<script type="application/ld+json" class="aioseop-schema">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://trinidadtribune.com/#organization","url":"https://trinidadtribune.com/","name":"Trinidad News","sameAs":[]},{"@type":"WebSite","@id":"https://trinidadtribune.com/#website","url":"https://trinidadtribune.com/","name":"Trinidad News","publisher":{"@id":"https://trinidadtribune.com/#organization"},"potentialAction":{"@type":"SearchAction","target":"https://trinidadtribune.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"WebPage","@id":"https://trinidadtribune.com/summer-2021-heats-up-with-new-royal-caribbean-cruises-from-bermuda/#webpage","url":"https://trinidadtribune.com/summer-2021-heats-up-with-new-royal-caribbean-cruises-from-bermuda/","inLanguage":"en-US","name":"Summer 2021 Heats Up With New Royal Caribbean Cruises From Bermuda","isPartOf":{"@id":"https://trinidadtribune.com/#website"},"datePublished":"2021-03-23T21:38:16-04:00","dateModified":"2021-03-23T21:38:19-04:00","description":" Beginning June and through August, Royal Caribbean International will bring more adventure to the tropics with a series of new 7-night cruises from first-time homeport Bermuda."},{"@type":"Article","@id":"https://trinidadtribune.com/summer-2021-heats-up-with-new-royal-caribbean-cruises-from-bermuda/#article","isPartOf":{"@id":"https://trinidadtribune.com/summer-2021-heats-up-with-new-royal-caribbean-cruises-from-bermuda/#webpage"},"author":{"@id":"https://trinidadtribune.com/author/admin/#author"},"headline":"Summer 2021 Heats Up With New Royal Caribbean Cruises From Bermuda","datePublished":"2021-03-23T21:38:16-04:00","dateModified":"2021-03-23T21:38:19-04:00","commentCount":0,"mainEntityOfPage":{"@id":"https://trinidadtribune.com/summer-2021-heats-up-with-new-royal-caribbean-cruises-from-bermuda/#webpage"},"publisher":{"@id":"https://trinidadtribune.com/#organization"},"articleSection":"PR News"},{"@type":"Person","@id":"https://trinidadtribune.com/author/admin/#author","name":"admin","sameAs":[],"image":{"@type":"ImageObject","@id":"https://trinidadtribune.com/#personlogo","url":"https://secure.gravatar.com/avatar/b563f2bedccc65bc94691e79a825a968?s=96&d=mm&r=g","width":96,"height":96,"caption":"admin"}}]}</script>
<link rel="canonical" href="https://trinidadtribune.com/summer-2021-heats-up-with-new-royal-caribbean-cruises-from-bermuda/" />

<link rel='dns-prefetch' href='//trinidadtribune.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Trinidad News &raquo; Feed" href="https://trinidadtribune.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Trinidad News &raquo; Comments Feed" href="https://trinidadtribune.com/comments/feed/" />

<script type="text/javascript" data-cfasync="false">
    (window.gaDevIds=window.gaDevIds||[]).push("dZGIzZG");
	var mi_version         = '7.14.0';
	var mi_track_user      = true;
	var mi_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-17218776-1';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}

	if ( 'undefined' === typeof gaOptout ) {
		function gaOptout() {
			__gaTrackerOptout();
		}
	}
	
	if ( mi_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

		__gaTracker('create', 'UA-17218776-1', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('send','pageview');
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + mi_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
					})();
		}
</script>

<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/trinidadtribune.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.4"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://trinidadtribune.com/wp-includes/css/dist/block-library/style.min.css?ver=5.4.4' type='text/css' media='all' />
<link rel='stylesheet' id='monsterinsights-popular-posts-style-css' href='https://trinidadtribune.com/wp-content/plugins/google-analytics-for-wordpress/assets/css/frontend.min.css?ver=7.14.0' type='text/css' media='all' />
<link rel='stylesheet' id='seek-google-fonts-css' href='https://fonts.googleapis.com/css?family=Raleway:400,400i,600,600i,700' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css' href='https://trinidadtribune.com/wp-content/themes/seek/assets/libraries/font-awesome/css/font-awesome.min.css?ver=5.4.4' type='text/css' media='all' />
<link rel='stylesheet' id='slick-css' href='https://trinidadtribune.com/wp-content/themes/seek/assets/libraries/slick/css/slick.css?ver=5.4.4' type='text/css' media='all' />
<link rel='stylesheet' id='magnific-css' href='https://trinidadtribune.com/wp-content/themes/seek/assets/libraries/magnific/css/magnific-popup.css?ver=5.4.4' type='text/css' media='all' />
<link rel='stylesheet' id='seek-style-css' href='https://trinidadtribune.com/wp-content/themes/seek/style.css?ver=5.4.4' type='text/css' media='all' />
<link rel='stylesheet' id='wp-advanced-rp-css-css' href='https://trinidadtribune.com/wp-content/plugins/advanced-recent-posts-widget-old/css/advanced-recent-posts-widget.css?ver=5.4.4' type='text/css' media='all' />
<script type='text/javascript' src='https://trinidadtribune.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://trinidadtribune.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[]","home_url":"https:\/\/trinidadtribune.com","hash_tracking":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='https://trinidadtribune.com/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend.min.js?ver=7.14.0'></script>
<link rel='https://api.w.org/' href='https://trinidadtribune.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://trinidadtribune.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://trinidadtribune.com/wp-includes/wlwmanifest.xml" />
<link rel='prev' title='Hamilton Reserve Bank, Formerly Nevis International Bank &#038; Trust, Completes Rebranding as A Leading Bank in the Hometown of Alexander Hamilton' href='https://trinidadtribune.com/hamilton-reserve-bank-formerly-nevis-international-bank-trust-completes-rebranding-as-a-leading-bank-in-the-hometown-of-alexander-hamilton/' />
<meta name="generator" content="WordPress 5.4.4" />
<link rel='shortlink' href='https://trinidadtribune.com/?p=549402' />
<link rel="alternate" type="application/json+oembed" href="https://trinidadtribune.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftrinidadtribune.com%2Fsummer-2021-heats-up-with-new-royal-caribbean-cruises-from-bermuda%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://trinidadtribune.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftrinidadtribune.com%2Fsummer-2021-heats-up-with-new-royal-caribbean-cruises-from-bermuda%2F&#038;format=xml" />
<style type='text/css'>                                                                span.collapsArch {border:0;
padding:0; 
margin:0; 
cursor:pointer;
}
#sidebar li.collapsArch:before {content:'';} 
#sidebar li.collapsArch {list-style-type:none}
#sidebar li.collapsArchPost {
     text-indent:-1em;
      list-style-type:none;
     margin:0 0 0 1em;}
#sidebar li.collapsArchPost:before {content: '\00BB \00A0' !important;} 
#sidebar li.collapsArch .sym {
       font-size:1.2em;
       font-family:Monaco, 'Andale Mono', 'FreeMono', 'Courier new', 'Courier', monospace;
       margin:2px 5px 0px 0; 
       line-height:.8em;
       padding:0;
       /* uncomment to put a box around +/-
       border:1px solid;
       height:.9em;
       display:inline-block;
       vertical-align:baseline;
       */
      }                                                </style>
<style type="text/css">
					.site-title a,
			.site-description {
				color: #dd0202;
			}
				</style>
</head>
<body class="post-template-default single single-post postid-549402 single-format-standard no-sidebar right-sidebar">
<div id="page" class="site">
<a class="skip-link screen-reader-text" href="#content">Skip to content</a>
<header id="masthead" class="site-header">
<div class="twp-topbar clearfix">
<div class="twp-topbar-content-left twp-float-left clearfix">
<div class="twp-current-date twp-float-left">
Friday, Mar 26, 2021 </div>
<div class="twp-title twp-title-with-arrow twp-title-primary twp-float-left">
Breaking News </div>
<div class="twp-breaking-news-section">
<div class="twp-ticket-pin-slider clearfix" data-slick='{"rtl": false}'>
<div class="twp-ticket-pin">
<div class="twp-image-section">
<a href="https://trinidadtribune.com/griffith-makes-fresh-appeal-for-passage-of-bail-amendment-bill-4/" class="data-bg d-block" data-background=""></a>
</div>
<div class="twp-articles-title">
<a href="https://trinidadtribune.com/griffith-makes-fresh-appeal-for-passage-of-bail-amendment-bill-4/">Griffith makes fresh appeal for passage of Bail Amendment Bill</a>
</div>
</div>
<div class="twp-ticket-pin">
<div class="twp-image-section">
<a href="https://trinidadtribune.com/griffith-makes-fresh-appeal-for-passage-of-bail-amendment-bill-3/" class="data-bg d-block" data-background=""></a>
</div>
<div class="twp-articles-title">
<a href="https://trinidadtribune.com/griffith-makes-fresh-appeal-for-passage-of-bail-amendment-bill-3/">Griffith makes fresh appeal for passage of Bail Amendment Bill</a>
</div>
</div>
<div class="twp-ticket-pin">
<div class="twp-image-section">
<a href="https://trinidadtribune.com/griffith-makes-fresh-appeal-for-passage-of-bail-amendment-bill/" class="data-bg d-block" data-background=""></a>
</div>
<div class="twp-articles-title">
<a href="https://trinidadtribune.com/griffith-makes-fresh-appeal-for-passage-of-bail-amendment-bill/">Griffith makes fresh appeal for passage of Bail Amendment Bill</a>
</div>
</div>
<div class="twp-ticket-pin">
<div class="twp-image-section">
<a href="https://trinidadtribune.com/sadness-for-his-student-criminologist-wants-errant-cops-disciplined-4/" class="data-bg d-block" data-background=""></a>
</div>
<div class="twp-articles-title">
<a href="https://trinidadtribune.com/sadness-for-his-student-criminologist-wants-errant-cops-disciplined-4/">Sadness for his student: Criminologist wants errant cops disciplined</a>
</div>
</div>
<div class="twp-ticket-pin">
<div class="twp-image-section">
<a href="https://trinidadtribune.com/griffith-makes-fresh-appeal-for-passage-of-bail-amendment-bill-2/" class="data-bg d-block" data-background=""></a>
</div>
<div class="twp-articles-title">
<a href="https://trinidadtribune.com/griffith-makes-fresh-appeal-for-passage-of-bail-amendment-bill-2/">Griffith makes fresh appeal for passage of Bail Amendment Bill</a>
</div>
</div>
<div class="twp-ticket-pin">
<div class="twp-image-section">
<a href="https://trinidadtribune.com/after-teen-electrocuted-stealing-copper-friends-home-set-on-fire-4/" class="data-bg d-block" data-background=""></a>
</div>
<div class="twp-articles-title">
<a href="https://trinidadtribune.com/after-teen-electrocuted-stealing-copper-friends-home-set-on-fire-4/">After teen electrocuted stealing copper, friend’s home set on fire</a>
</div>
</div>
<div class="twp-ticket-pin">
<div class="twp-image-section">
<a href="https://trinidadtribune.com/sadness-for-his-student-criminologist-wants-errant-cops-disciplined/" class="data-bg d-block" data-background=""></a>
</div>
<div class="twp-articles-title">
<a href="https://trinidadtribune.com/sadness-for-his-student-criminologist-wants-errant-cops-disciplined/">Sadness for his student: Criminologist wants errant cops disciplined</a>
</div>
</div>
<div class="twp-ticket-pin">
<div class="twp-image-section">
<a href="https://trinidadtribune.com/sadness-for-his-student-criminologist-wants-errant-cops-disciplined-2/" class="data-bg d-block" data-background=""></a>
</div>
<div class="twp-articles-title">
<a href="https://trinidadtribune.com/sadness-for-his-student-criminologist-wants-errant-cops-disciplined-2/">Sadness for his student: Criminologist wants errant cops disciplined</a>
</div>
</div>
<div class="twp-ticket-pin">
<div class="twp-image-section">
<a href="https://trinidadtribune.com/sadness-for-his-student-criminologist-wants-errant-cops-disciplined-3/" class="data-bg d-block" data-background=""></a>
</div>
<div class="twp-articles-title">
<a href="https://trinidadtribune.com/sadness-for-his-student-criminologist-wants-errant-cops-disciplined-3/">Sadness for his student: Criminologist wants errant cops disciplined</a>
</div>
</div>
<div class="twp-ticket-pin">
<div class="twp-image-section">
<a href="https://trinidadtribune.com/daughter-mom-and-friend-admit-to-murder-of-abusive-man-3/" class="data-bg d-block" data-background=""></a>
</div>
<div class="twp-articles-title">
<a href="https://trinidadtribune.com/daughter-mom-and-friend-admit-to-murder-of-abusive-man-3/">Daughter, mom and friend admit to murder of abusive man</a>
</div>
</div>
<div class="twp-ticket-pin">
<div class="twp-image-section">
<a href="https://trinidadtribune.com/after-teen-electrocuted-stealing-copper-friends-home-set-on-fire/" class="data-bg d-block" data-background=""></a>
</div>
<div class="twp-articles-title">
<a href="https://trinidadtribune.com/after-teen-electrocuted-stealing-copper-friends-home-set-on-fire/">After teen electrocuted stealing copper, friend’s home set on fire</a>
</div>
</div>
<div class="twp-ticket-pin">
<div class="twp-image-section">
<a href="https://trinidadtribune.com/after-teen-electrocuted-stealing-copper-friends-home-set-on-fire-2/" class="data-bg d-block" data-background=""></a>
</div>
<div class="twp-articles-title">
<a href="https://trinidadtribune.com/after-teen-electrocuted-stealing-copper-friends-home-set-on-fire-2/">After teen electrocuted stealing copper, friend’s home set on fire</a>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="twp-site-branding data-bg " data-background="">
<div class="container">
<div class="twp-wrapper">
<div class="twp-logo">
<div class="twp-image-wrapper"></div>
<p class="site-title"><a href="https://trinidadtribune.com/" rel="home">Trinidad News</a></p>
<p class="site-description">Daily News from Trinidad and Tobago</p>
</div>
</div>
</div>
</div>
<nav id="site-navigation" class="twp-navigation">
<div class="twp-nav-menu-section">
<div class="container">
<div class="twp-row twp-wrapper">
<div class="twp-menu-section desktop twp-d-flex">
<div class="twp-nav-menu"><ul id="primary-menu" class="twp-nav-menu"><li class="brand-home"><a title="Home" href="https://trinidadtribune.com"><span class='fa fa-home'></span></a></li><li id="menu-item-127129" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-127129"><a href="http://www.trinidadtribune.com/">Home</a></li>
<li id="menu-item-127602" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-127602"><a href="https://trinidadtribune.com/category/latest-news/">Latest News</a></li>
<li id="menu-item-127598" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-127598"><a href="http://www.trinidadtribune.com/category/caribbean-news/">Caribbean News</a></li>
<li id="menu-item-127599" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-127599"><a href="http://www.trinidadtribune.com/category/pr-news/">PR News</a></li>
</ul></div> <div class="twp-menu-icon-section">
<div class="twp-menu-icon twp-menu-icon-white" id="twp-menu-icon">
<span></span>
</div>
</div>
</div>
<div class="twp-site-features">

<div class="theme-mode header-theme-mode"></div>
<div class="twp-trending" id="nav-latest-news">
<i class="fa fa-flash"></i>
</div>
<div class="twp-search" id="search">
<i class="fa fa-search"></i>
</div>
</div>
</div>
</div>
<div class="twp-progress-bar" id="progressbar">
</div>
</div>
<div class="twp-search-field-section" id="search-field">
<div class="container">
<div class="twp-search-field-wrapper">
<div class="twp-search-field">
<form role="search" method="get" class="search-form" action="https://trinidadtribune.com/">
<label>
<span class="screen-reader-text">Search for:</span>
<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
</label>
<input type="submit" class="search-submit" value="Search" />
</form> </div>
<div class="twp-close-icon-section">
<span class="twp-close-icon" id="search-close">
<span></span>
<span></span>
</span>
</div>
</div>
</div>
</div>

<div class="twp-article-list" id="nav-latest-news-field">
<div class="container">
<header class="twp-article-header">
<h3>
Trending Now </h3>
<div class="twp-close-icon-section">
<span class="twp-close-icon" id="latest-news-close">
 <span></span>
<span></span>
</span>
</div>
</header>
<div class="twp-row">

<div class="twp-col-4 twp-article-border">
<div class="twp-article">
<div class="twp-units">
1 </div>
<div class="twp-description">
<h4><a href="https://trinidadtribune.com/sanders-camp-sees-opportunity-as-southern-state-voting-wraps-fox-news/">Sanders camp sees opportunity as Southern state voting wraps &#8211; Fox News</a></h4>
<div class="twp-author-meta">
<span class="twp-post-date">
<i class="fa fa-clock-o"></i>
5 years ago </span>
</div>
</div>
</div>
</div>

<div class="twp-col-4 twp-article-border">
<div class="twp-article">
<div class="twp-units">
2 </div>
<div class="twp-description">
<h4><a href="https://trinidadtribune.com/939-covid19-samples-submitted-death-toll-remains-at-8-2/">939 covid19 samples submitted, death toll remains at 8</a></h4>
<div class="twp-author-meta">
<span class="twp-post-date">
<i class="fa fa-clock-o"></i>
12 months ago </span>
</div>
</div>
</div>
</div>

<div class="twp-col-4 twp-article-border">
<div class="twp-article">
<div class="twp-units">
3 </div>
<div class="twp-description">
<h4><a href="https://trinidadtribune.com/skiffle-thrills-with-voices-and-sweet-steel-trinidad-tobago-express/">Skiffle thrills with voices and sweet steel &#8211; Trinidad &amp; Tobago Express</a></h4>
<div class="twp-author-meta">
<span class="twp-post-date">
<i class="fa fa-clock-o"></i>
8 years ago </span>
</div>
</div>
</div>
</div>

<div class="twp-col-4 twp-article-border">
<div class="twp-article">
<div class="twp-units">
4 </div>
<div class="twp-description">
<h4><a href="https://trinidadtribune.com/bari-replaces-alam-as-pakistan-team-manager-espncricinfo-com/">Bari replaces Alam as Pakistan team manager &#8211; ESPNcricinfo.com</a></h4>
<div class="twp-author-meta">
<span class="twp-post-date">
<i class="fa fa-clock-o"></i>
5 years ago </span>
</div>
</div>
</div>
</div>

<div class="twp-col-4 twp-article-border">
<div class="twp-article">
<div class="twp-units">
5 </div>
<div class="twp-description">
<h4><a href="https://trinidadtribune.com/crystal-dunn-bursts-into-spotlight-for-us-soccer-team-in-transition-washington-post/">Crystal Dunn bursts into spotlight for US soccer team in transition &#8211; Washington Post</a></h4>
<div class="twp-author-meta">
<span class="twp-post-date">
<i class="fa fa-clock-o"></i>
5 years ago </span>
</div>
</div>
</div>
</div>

<div class="twp-col-4 twp-article-border">
<div class="twp-article">
<div class="twp-units">
6 </div>
<div class="twp-description">
<h4><a href="https://trinidadtribune.com/tkr-let-ramdin-go-3/">TKR let Ramdin go</a></h4>
<div class="twp-author-meta">
<span class="twp-post-date">
<i class="fa fa-clock-o"></i>
11 months ago </span>
</div>
</div>
</div>
</div>

<div class="twp-col-4 twp-article-border">
<div class="twp-article">
<div class="twp-units">
7 </div>
<div class="twp-description">
<h4><a href="https://trinidadtribune.com/abstractmany-%ea%b8%b0%ec%88%a0%ec%a0%81%ec%9c%bc%eb%a1%9c-%ec%a4%91%ec%9a%94%ed%95%9c-%ed%95%a9%ec%84%b1/">AbstractMany 기술적으로 중요한 합성</a></h4>
<div class="twp-author-meta">
<span class="twp-post-date">
<i class="fa fa-clock-o"></i>
2 years ago </span>
</div>
</div>
</div>
</div>

<div class="twp-col-4 twp-article-border">
<div class="twp-article">
<div class="twp-units">
8 </div>
<div class="twp-description">
<h4><a href="https://trinidadtribune.com/%ec%9d%b4%eb%8a%94-%ec%a7%80%ec%b6%9c%ec%9d%84-%eb%8a%98%eb%a6%ac%eb%8a%94-%ea%b3%b5%ed%99%94%eb%8b%b9-%ec%9b%90%eb%93%a4/">이는 지출을 늘리는 공화당 원들</a></h4>
<div class="twp-author-meta">
<span class="twp-post-date">
<i class="fa fa-clock-o"></i>
2 years ago </span>
</div>
</div>
</div>
</div>

<div class="twp-col-4 twp-article-border">
<div class="twp-article">
<div class="twp-units">
9 </div>
<div class="twp-description">
<h4><a href="https://trinidadtribune.com/ngc-touchstone-sign-gas-supply-partnership/">NGC, Touchstone sign gas supply partnership</a></h4>
<div class="twp-author-meta">
<span class="twp-post-date">
<i class="fa fa-clock-o"></i>
3 months ago </span>
</div>
</div>
</div>
</div>

<div class="twp-col-4 twp-article-border">
<div class="twp-article">
<div class="twp-units">
10 </div>
<div class="twp-description">
<h4><a href="https://trinidadtribune.com/trinidad-drilling-ltd-to-release-second-quarter-2014-results-and-to-hold-canada-newswire-press-release/">Trinidad Drilling Ltd. to release second quarter 2014 results and to hold &#8230; &#8211; Canada NewsWire (press release)</a></h4>
<div class="twp-author-meta">
<span class="twp-post-date">
<i class="fa fa-clock-o"></i>
7 years ago </span>
</div>
</div>
</div>
</div>

<div class="twp-col-4 twp-article-border">
<div class="twp-article">
<div class="twp-units">
11 </div>
<div class="twp-description">
<h4><a href="https://trinidadtribune.com/four-held-by-police-3/">Four held by police</a></h4>
<div class="twp-author-meta">
<span class="twp-post-date">
<i class="fa fa-clock-o"></i>
5 months ago </span>
</div>
</div>
</div>
</div>

<div class="twp-col-4 twp-article-border">
<div class="twp-article">
<div class="twp-units">
12 </div>
<div class="twp-description">
<h4><a href="https://trinidadtribune.com/three-arrested-for-house-breaking-in-police-exercise-2/">Three arrested for house-breaking in police exercise</a></h4>
<div class="twp-author-meta">
<span class="twp-post-date">
<i class="fa fa-clock-o"></i>
5 months ago </span>
</div>
</div>
</div>
</div>
</div>
</div>
</div>

</nav>
</header>
<div class="twp-mobile-menu">
<div class="twp-mobile-close-icon">
<span class="twp-close-icon twp-close-icon-sm twp-close-icon-white twp-rotate-90" id="twp-mobile-close">
<span></span>
<span></span>
</span>
</div>
</div>
<div class="twp-body-overlay" id="overlay"></div>

<div class="twp-breadcrumbs">
<div class="container">
<div role="navigation" aria-label="Breadcrumbs" class="breadcrumb-trail breadcrumbs" itemprop="breadcrumb"><ul class="trail-items" itemscope itemtype="http://schema.org/BreadcrumbList"><meta name="numberOfItems" content="3" /><meta name="itemListOrder" content="Ascending" /><li itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem" class="trail-item trail-begin"><a href="https://trinidadtribune.com/" rel="home" itemprop="item"><span itemprop="name">Home</span></a><meta itemprop="position" content="1" /></li><li itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem" class="trail-item"><a href="https://trinidadtribune.com/category/pr-news/" itemprop="item"><span itemprop="name">PR News</span></a><meta itemprop="position" content="2" /></li><li itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem" class="trail-item trail-end"><span itemprop="item"><span itemprop="name">Summer 2021 Heats Up With New Royal Caribbean Cruises From Bermuda</span></span><meta itemprop="position" content="3" /></li></ul></div> </div>
</div>

<div id="content" class="site-content">
<div id="primary" class="content-area">
<main id="main" class="site-main">
<article id="post-549402" class="twp-article-post post-549402 post type-post status-publish format-standard hentry category-pr-news">
<header class="entry-header">
<div class="twp-categories-with-bg twp-categories-with-bg-primary">
<ul class="cat-links"><li>
<a href="https://trinidadtribune.com/category/pr-news/" alt="View all posts in PR News">
PR News
</a>
</li></ul> </div>
<h1 class="entry-title">
<a href="" rel="bookmark">
Summer 2021 Heats Up With New Royal Caribbean Cruises From Bermuda </a>
</h1>
<div class="twp-author-meta">
<a href="https://trinidadtribune.com/author/admin/">
<span class="twp-author-image"><img src="https://secure.gravatar.com/avatar/b563f2bedccc65bc94691e79a825a968?s=150&#038;d=mm&#038;r=g"></span>
<span class="twp-author-caption">admin</span>
</a>
<span class="twp-post-date">
<i class="fa fa-clock-o"></i>
3 days ago </span>
</div>
</header>
<div class="entry-content">
<p>New 7-night Cruises Feature Perfect Day at CocoCay and an Overnight in Bermuda</p>
<p>MIAMI, March 23, 2021 /PRNewswire-HISPANIC PR WIRE/ &#8212; Vacationers looking to soak up the sun and walk the pink sand beaches of Bermuda and the white sandy beaches of The Bahamas this summer need look no further than Vision of the Seas. Beginning June and through August, Royal Caribbean International will bring more adventure to the tropics with a series of new 7-night cruises from first-time homeport Bermuda. In store for guests who sail on Vision is an overnight to explore Bermuda&#8217;s culture, history and cuisine as well as a full day at Perfect Day at CocoCay, Royal Caribbean&#8217;s top-rated private island destination in The Bahamas.</p>
<p>The new 2021 summer itineraries from Bermuda will open for bookings on Monday, March 29 and depart as soon as June 26. Sailing with vaccinated crew, the cruises – at this time – will be available to adult guests who are fully vaccinated against COVID-19 and those under the age of 18 with negative test results. This current health and safety measure, like others, may evolve as they are evaluated on an ongoing basis.</p>
<p>&#8220;We are thankful to the government and people of Bermuda for welcoming us to their beautiful island nation with open arms as Vision of the Seas&#8217; new homeport. This is another step in our safe and measured return to sailing beginning in June,&#8221; said Michael Bayley, president and CEO, Royal Caribbean International. &#8220;Travelers are eager to venture out gradually and start cruising again. By adding a second unique option to sail the Caribbean from a destination as rich and vibrant as Bermuda, we&#8217;re offering guests choice in how they can enjoy their well-deserved vacations this summer.&#8221;</p>
<p>The pink sand beaches and charming, colorful homes of Bermuda will be where vacationers can start and end their 7-night cruise in paradise, a destination that is also a prime spot for travelers to extend their time ashore, before or after the cruise, by staying at one of the island&#8217;s world-class hotels and resorts. While Vision is docked at the Royal Naval Dockyard, guests can enjoy quality time exploring the island nation&#8217;s culture and natural beauty throughout an overnight stay.</p>
<p>Plus, guests of all ages will have the chance to add to the excitement with a visit to Royal Caribbean&#8217;s Perfect Day at CocoCay. The private island destination is home to a lineup of first-of-their-kind thrills and one-of-a-kind ways to chill, ranging from 13 jaw-dropping waterslides at Thrill Waterpark, including the tallest waterslide in North America – Daredevil&#8217;s Peak; Oasis Lagoon, the largest freshwater pool in the Caribbean; Up, Up &amp; Away, the helium balloon that floats up to 450 feet in the air; and the first floating cabanas in The Bahamas at Coco Beach Club.</p>
<p>&#8220;Bermuda has safely and responsibly managed the reopening of its tourism economy by air, and we will meet the challenge of doing the same for the cruise industry. We look forward to homeporting Royal Caribbean&#8217;s Vision of the Seas this June as part of the island&#8217;s strategic tourism recovery planning which, as always, is guided by science,&#8221; said Premier the Hon. E. David Burt, JP, MP, Bermuda.</p>
<p>Vacationers can rest assured their well-being and that of the crew members and communities visited are Royal Caribbean&#8217;s top priorities. Details on the health and safety measures to be implemented will be announced at a later date. The comprehensive, multilayered health and safety measures to come will continue to be led by science and leverage expert guidance from the Healthy Sail Panel, Royal Caribbean Group&#8217;s Head of Public Health and Chief Medical Officer, and local government and health authorities.</p>
<p>In addition, travelers must meet the travel requirements of Bermuda. This currently includes receiving a negative PCR test result before traveling, testing upon arrival into the country and filling out appropriate entry forms. The most up-to-date policies can be found on Bermuda&#8217;s website.</p>
<p>&#8220;We look forward to welcoming Royal Caribbean passengers back to our shores and the opportunity for pre- and post-cruise stays in Bermuda. I am very excited that Bermuda will commence safe cruising this summer with our partner Royal Caribbean for their homeporting initiative from Bermuda to their private island Perfect Day at CocoCay,&#8221; said The Hon. W. Lawrence Scott, JP, MP, Minister of Transport, Bermuda.</p>
<p>Royal Caribbean&#8217;s 7-night sailings from Bermuda continue the cruise line&#8217;s measured and safe return to cruising the world once again, following months of successful cruises in Singapore with more than 50,000 guests to date who have now sailed aboard Quantum of the Seas, and the recent announcements of plans for the highly anticipated Odyssey of the Seas to cruise from Haifa, Israel and cruises from The Bahamas with Adventure of the Seas. For more information on Vision&#8217;s new summer cruises, click here.</p>
<p>About Royal Caribbean International</p>
<p>Royal Caribbean International has been delivering innovation at sea for more than 50 years. Each successive class of ships is an architectural marvel featuring the latest technology and guest experiences for today&#8217;s adventurous traveler. The cruise line continues to revolutionize vacations with itineraries to more than 270 destinations in 72 countries on six continents, including Royal Caribbean&#8217;s private island destination in The Bahamas, Perfect Day at CocoCay, the first in the Perfect Day Island Collection. Royal Caribbean has also been voted &#8220;Best Cruise Line Overall&#8221; for 18 consecutive years in the Travel Weekly Readers&#8217; Choice Awards.</p>
<p>Media can stay up to date by following @RoyalCaribPR on Twitter and visiting RoyalCaribbeanPressCenter.com. For additional information or to make reservations, vacationers can call their travel advisor; visit RoyalCaribbean.com; or call (800) ROYAL-CARIBBEAN.</p>
<p>Royal Caribbean International is applying the recommendations of its Healthy Sail Panel of public health and scientific experts to provide a safer and healthier cruise vacation on all of its sailings. Health and safety protocols, regional travel restrictions and clearance to visit ports of call, are subject to change based on ongoing evaluation, public health standards, and government requirements. U.S. cruises and guests: For more information on the latest health and travel alerts, U.S. government travel advisories, please visit www.royalcaribbean.com/cruise-ships/itinerary-updates or consult travel advisories, warnings or recommendations relating to cruise travel on applicable government websites.</p>
</div>
</article>
<div class="twp-related-post-section">
<div class="container">
<h2 class="twp-title twp-title-with-dashed">You May Like</h2>
<ul class="twp-related-post-list">
<li class="twp-related-post twp-d-flex">
<div class="twp-image-section twp-image-hover">
<a href="https://trinidadtribune.com/photo-release-arkay-is-launching-a-collection-of-16-halal-drinks-created-especially-for-our-muslim-friends/" class="data-bg" data-background=""></a>
</div>
<div class="twp-desc twp-bg-light-gray">
<div class="twp-categories-with-bg twp-categories-with-bg-primary">
<ul class="cat-links"><li>
<a href="https://trinidadtribune.com/category/pr-news/" alt="View all posts in PR News">
PR News
</a>
</li></ul> </div>
<h3><a href="https://trinidadtribune.com/photo-release-arkay-is-launching-a-collection-of-16-halal-drinks-created-especially-for-our-muslim-friends/">Photo Release — ArKay is Launching a Collection of 16 Halal Drinks Created Especially for Our Muslim Friends</a></h3>
<div class="twp-social-share-section">
<div class="twp-author-meta m-0">
<a href="https://trinidadtribune.com/author/admin/">
<span class="twp-author-image"><img src="https://secure.gravatar.com/avatar/b563f2bedccc65bc94691e79a825a968?s=150&#038;d=mm&#038;r=g"></span>
<span class="twp-author-caption">admin</span>
</a>
<span class="twp-post-date">
<i class="fa fa-clock-o"></i>
6 years ago </span>
</div>
</div>
</div>
</li>
<li class="twp-related-post twp-d-flex">
<div class="twp-image-section twp-image-hover">
<a href="https://trinidadtribune.com/cloud-carib-ranked-42nd-among-top-100-cloud-services-providers/" class="data-bg" data-background=""></a>
</div>
 <div class="twp-desc twp-bg-light-gray">
<div class="twp-categories-with-bg twp-categories-with-bg-primary">
<ul class="cat-links"><li>
<a href="https://trinidadtribune.com/category/pr-news/" alt="View all posts in PR News">
PR News
</a>
</li></ul> </div>
<h3><a href="https://trinidadtribune.com/cloud-carib-ranked-42nd-among-top-100-cloud-services-providers/">Cloud Carib Ranked 42nd Among Top 100 Cloud Services Providers</a></h3>
<div class="twp-social-share-section">
<div class="twp-author-meta m-0">
<a href="https://trinidadtribune.com/author/admin/">
<span class="twp-author-image"><img src="https://secure.gravatar.com/avatar/b563f2bedccc65bc94691e79a825a968?s=150&#038;d=mm&#038;r=g"></span>
<span class="twp-author-caption">admin</span>
</a>
<span class="twp-post-date">
<i class="fa fa-clock-o"></i>
3 years ago </span>
</div>
</div>
</div>
</li>
<li class="twp-related-post twp-d-flex">
<div class="twp-image-section twp-image-hover">
<a href="https://trinidadtribune.com/generac-new-options-in-backup-power-generation-3/" class="data-bg" data-background=""></a>
</div>
<div class="twp-desc twp-bg-light-gray">
<div class="twp-categories-with-bg twp-categories-with-bg-primary">
<ul class="cat-links"><li>
<a href="https://trinidadtribune.com/category/pr-news/" alt="View all posts in PR News">
PR News
</a>
</li></ul> </div>
<h3><a href="https://trinidadtribune.com/generac-new-options-in-backup-power-generation-3/">Generac: New Options in Backup Power Generation</a></h3>
<div class="twp-social-share-section">
<div class="twp-author-meta m-0">
<a href="https://trinidadtribune.com/author/admin/">
<span class="twp-author-image"><img src="https://secure.gravatar.com/avatar/b563f2bedccc65bc94691e79a825a968?s=150&#038;d=mm&#038;r=g"></span>
<span class="twp-author-caption">admin</span>
</a>
<span class="twp-post-date">
<i class="fa fa-clock-o"></i>
3 years ago </span>
</div>
 </div>
</div>
</li>
<li class="twp-related-post twp-d-flex">
<div class="twp-image-section twp-image-hover">
<a href="https://trinidadtribune.com/correction-in-total-covid-19-deaths-for-latin-american-and-caribbean-nations/" class="data-bg" data-background=""></a>
</div>
<div class="twp-desc twp-bg-light-gray">
<div class="twp-categories-with-bg twp-categories-with-bg-primary">
<ul class="cat-links"><li>
<a href="https://trinidadtribune.com/category/pr-news/" alt="View all posts in PR News">
PR News
</a>
</li></ul> </div>
<h3><a href="https://trinidadtribune.com/correction-in-total-covid-19-deaths-for-latin-american-and-caribbean-nations/">Correction in Total COVID-19 Deaths for Latin American and Caribbean Nations</a></h3>
<div class="twp-social-share-section">
<div class="twp-author-meta m-0">
<a href="https://trinidadtribune.com/author/admin/">
<span class="twp-author-image"><img src="https://secure.gravatar.com/avatar/b563f2bedccc65bc94691e79a825a968?s=150&#038;d=mm&#038;r=g"></span>
<span class="twp-author-caption">admin</span>
</a>
<span class="twp-post-date">
<i class="fa fa-clock-o"></i>
9 months ago </span>
</div>
</div>
</div>
</li>
<li class="twp-related-post twp-d-flex">
<div class="twp-image-section twp-image-hover">
<a href="https://trinidadtribune.com/internationalcaribbean-stars-to-shine-at-caribbeantales-film-festival-gala-launch/" class="data-bg" data-background=""></a>
</div>
<div class="twp-desc twp-bg-light-gray">
<div class="twp-categories-with-bg twp-categories-with-bg-primary">
<ul class="cat-links"><li>
<a href="https://trinidadtribune.com/category/pr-news/" alt="View all posts in PR News">
PR News
</a>
</li></ul> </div>
<h3><a href="https://trinidadtribune.com/internationalcaribbean-stars-to-shine-at-caribbeantales-film-festival-gala-launch/">InternationalCaribbean Stars To Shine At CaribbeanTales Film Festival Gala Launch</a></h3>
<div class="twp-social-share-section">
<div class="twp-author-meta m-0">
<a href="https://trinidadtribune.com/author/admin/">
<span class="twp-author-image"><img src="https://secure.gravatar.com/avatar/b563f2bedccc65bc94691e79a825a968?s=150&#038;d=mm&#038;r=g"></span>
<span class="twp-author-caption">admin</span>
</a>
<span class="twp-post-date">
<i class="fa fa-clock-o"></i>
4 years ago </span>
</div>
</div>
</div>
</li>
<li class="twp-related-post twp-d-flex">
<div class="twp-image-section twp-image-hover">
<a href="https://trinidadtribune.com/introducing-the-breitling-squad-concept-the-breitling-cinema-squad-with-brad-pitt-charlize-theron-adam-driver-and-daniel-wu-15/" class="data-bg" data-background=""></a>
</div>
<div class="twp-desc twp-bg-light-gray">
<div class="twp-categories-with-bg twp-categories-with-bg-primary">
<ul class="cat-links"><li>
<a href="https://trinidadtribune.com/category/pr-news/" alt="View all posts in PR News">
PR News
</a>
</li></ul> </div>
<h3><a href="https://trinidadtribune.com/introducing-the-breitling-squad-concept-the-breitling-cinema-squad-with-brad-pitt-charlize-theron-adam-driver-and-daniel-wu-15/">Introducing The Breitling Squad Concept, The Breitling Cinema Squad With Brad Pitt, Charlize Theron, Adam Driver, And Daniel Wu</a></h3>
<div class="twp-social-share-section">
<div class="twp-author-meta m-0">
<a href="https://trinidadtribune.com/author/admin/">
<span class="twp-author-image"><img src="https://secure.gravatar.com/avatar/b563f2bedccc65bc94691e79a825a968?s=150&#038;d=mm&#038;r=g"></span>
<span class="twp-author-caption">admin</span>
</a>
<span class="twp-post-date">
<i class="fa fa-clock-o"></i>
3 years ago </span>
</div>
</div>
</div>
</li>
</ul>
</div>
</div>
</main>
</div>
</div>


<div class="twp-footer-widget-section">
<div class="container  twp-footer-border">
<div class="twp-row">
</div>
</div>
</div>
<div class="twp-footer-social-section">
<div class="container">
<div class="twp-footer-social">
</div>
</div>
</div>
<footer id="colophon" class="site-footer">
<div class="container">
<div class="site-info">
WordPress Theme: Seek by <a href="https://themeinwp.com" target="_blank" rel="designer">ThemeInWP </a> </div>
</div>
</footer>
<div class="twp-scroll-top" id="scroll-top">
<span><i class="fa fa-chevron-up"></i></span>
</div>
</div>
<script type='text/javascript' src='https://trinidadtribune.com/wp-content/themes/seek/js/navigation.js?ver=20151215'></script>
<script type='text/javascript' src='https://trinidadtribune.com/wp-content/themes/seek/assets/libraries/slick/js/slick.min.js?ver=5.4.4'></script>
<script type='text/javascript' src='https://trinidadtribune.com/wp-content/themes/seek/assets/libraries/magnific/js/jquery.magnific-popup.min.js?ver=5.4.4'></script>
<script type='text/javascript' src='https://trinidadtribune.com/wp-content/themes/seek/assets/libraries/color-switcher/color-switcher.js?ver=5.4.4'></script>
<script type='text/javascript' src='https://trinidadtribune.com/wp-content/themes/seek/js/skip-link-focus-fix.js?ver=20151215'></script>
<script type='text/javascript' src='https://trinidadtribune.com/wp-content/themes/seek/assets/libraries/theiaStickySidebar/theia-sticky-sidebar.min.js?ver=5.4.4'></script>
<script type='text/javascript' src='https://trinidadtribune.com/wp-content/themes/seek/assets/twp/js/main.js?ver=5.4.4'></script>
<script type='text/javascript' src='https://trinidadtribune.com/wp-includes/js/wp-embed.min.js?ver=5.4.4'></script>
</body>
</html>
