<!doctype html>
<html lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="https://gmpg.org/xfn/11">
<title>Trinidad Tribune</title>
<style type="text/css">
                    .twp-site-branding .twp-logo,
            .twp-site-branding.twp-overlay .twp-logo,
            .twp-site-branding .twp-logo a,
            .twp-site-branding .twp-logo a:visited
            .twp-site-branding.twp-overlay .twp-logo a,
            .twp-site-branding.twp-overlay .twp-logo a:visited{
                color: #dd1a1a;
            }
                </style>

<meta name="description" content="Trinidad &amp; Tobago News" />
<script type="application/ld+json" class="aioseop-schema">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://trinidadtribune.com/#organization","url":"https://trinidadtribune.com/","name":"Trinidad News","sameAs":[]},{"@type":"WebSite","@id":"https://trinidadtribune.com/#website","url":"https://trinidadtribune.com/","name":"Trinidad News","publisher":{"@id":"https://trinidadtribune.com/#organization"},"potentialAction":{"@type":"SearchAction","target":"https://trinidadtribune.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"WebPage","@id":"https://trinidadtribune.com/michelin-star-chef-antonio-mellino-heads-quattro-passi-at-the-cliff/#webpage","url":"https://trinidadtribune.com/michelin-star-chef-antonio-mellino-heads-quattro-passi-at-the-cliff/","inLanguage":"en-US","name":"Michelin Star Chef, Antonio Mellino Heads Quattro Passi at The Cliff","isPartOf":{"@id":"https://trinidadtribune.com/#website"},"datePublished":"2021-07-27T23:13:57-04:00","dateModified":"2021-07-27T23:13:59-04:00"},{"@type":"Article","@id":"https://trinidadtribune.com/michelin-star-chef-antonio-mellino-heads-quattro-passi-at-the-cliff/#article","isPartOf":{"@id":"https://trinidadtribune.com/michelin-star-chef-antonio-mellino-heads-quattro-passi-at-the-cliff/#webpage"},"author":{"@id":"https://trinidadtribune.com/author/admin/#author"},"headline":"Michelin Star Chef, Antonio Mellino Heads Quattro Passi at The Cliff","datePublished":"2021-07-27T23:13:57-04:00","dateModified":"2021-07-27T23:13:59-04:00","commentCount":0,"mainEntityOfPage":{"@id":"https://trinidadtribune.com/michelin-star-chef-antonio-mellino-heads-quattro-passi-at-the-cliff/#webpage"},"publisher":{"@id":"https://trinidadtribune.com/#organization"},"articleSection":"PR News"},{"@type":"Person","@id":"https://trinidadtribune.com/author/admin/#author","name":"admin","sameAs":[],"image":{"@type":"ImageObject","@id":"https://trinidadtribune.com/#personlogo","url":"https://secure.gravatar.com/avatar/b563f2bedccc65bc94691e79a825a968?s=96&d=mm&r=g","width":96,"height":96,"caption":"admin"}}]}</script>
<link rel="canonical" href="https://trinidadtribune.com/michelin-star-chef-antonio-mellino-heads-quattro-passi-at-the-cliff/" />

<link rel='dns-prefetch' href='//trinidadtribune.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Trinidad News &raquo; Feed" href="https://trinidadtribune.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Trinidad News &raquo; Comments Feed" href="https://trinidadtribune.com/comments/feed/" />

<script type="text/javascript" data-cfasync="false">
    (window.gaDevIds=window.gaDevIds||[]).push("dZGIzZG");
	var mi_version         = '7.14.0';
	var mi_track_user      = true;
	var mi_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-17218776-1';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}

	if ( 'undefined' === typeof gaOptout ) {
		function gaOptout() {
			__gaTrackerOptout();
		}
	}
	
	if ( mi_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

		__gaTracker('create', 'UA-17218776-1', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('send','pageview');
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + mi_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
					})();
		}
</script>

<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/trinidadtribune.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.6"}};
			/*! This file is auto-generated */
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://trinidadtribune.com/wp-includes/css/dist/block-library/style.min.css?ver=5.4.6' type='text/css' media='all' />
<link rel='stylesheet' id='monsterinsights-popular-posts-style-css' href='https://trinidadtribune.com/wp-content/plugins/google-analytics-for-wordpress/assets/css/frontend.min.css?ver=7.14.0' type='text/css' media='all' />
<link rel='stylesheet' id='seek-google-fonts-css' href='https://fonts.googleapis.com/css?family=Raleway:400,400i,600,600i,700' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css' href='https://trinidadtribune.com/wp-content/themes/seek/assets/libraries/font-awesome/css/font-awesome.min.css?ver=5.4.6' type='text/css' media='all' />
<link rel='stylesheet' id='slick-css' href='https://trinidadtribune.com/wp-content/themes/seek/assets/libraries/slick/css/slick.css?ver=5.4.6' type='text/css' media='all' />
<link rel='stylesheet' id='magnific-css' href='https://trinidadtribune.com/wp-content/themes/seek/assets/libraries/magnific/css/magnific-popup.css?ver=5.4.6' type='text/css' media='all' />
<link rel='stylesheet' id='seek-style-css' href='https://trinidadtribune.com/wp-content/themes/seek/style.css?ver=5.4.6' type='text/css' media='all' />
<link rel='stylesheet' id='wp-advanced-rp-css-css' href='https://trinidadtribune.com/wp-content/plugins/advanced-recent-posts-widget-old/css/advanced-recent-posts-widget.css?ver=5.4.6' type='text/css' media='all' />
<script type='text/javascript' src='https://trinidadtribune.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://trinidadtribune.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[]","home_url":"https:\/\/trinidadtribune.com","hash_tracking":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='https://trinidadtribune.com/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend.min.js?ver=7.14.0'></script>
<link rel='https://api.w.org/' href='https://trinidadtribune.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://trinidadtribune.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://trinidadtribune.com/wp-includes/wlwmanifest.xml" />
<link rel='prev' title='Parkland Corporation Announces Date of 2021 Second Quarter Results' href='https://trinidadtribune.com/parkland-corporation-announces-date-of-2021-second-quarter-results/' />
<link rel='next' title='ibex Takes Firm Hold of BPO Industry Leadership in Jamaica &#8211; Opens its Fifth Site in Five Years' href='https://trinidadtribune.com/ibex-takes-firm-hold-of-bpo-industry-leadership-in-jamaica-opens-its-fifth-site-in-five-years/' />
<meta name="generator" content="WordPress 5.4.6" />
<link rel='shortlink' href='https://trinidadtribune.com/?p=549467' />
<link rel="alternate" type="application/json+oembed" href="https://trinidadtribune.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftrinidadtribune.com%2Fmichelin-star-chef-antonio-mellino-heads-quattro-passi-at-the-cliff%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://trinidadtribune.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftrinidadtribune.com%2Fmichelin-star-chef-antonio-mellino-heads-quattro-passi-at-the-cliff%2F&#038;format=xml" />
<style type='text/css'>                                                                span.collapsArch {border:0;
padding:0; 
margin:0; 
cursor:pointer;
}
#sidebar li.collapsArch:before {content:'';} 
#sidebar li.collapsArch {list-style-type:none}
#sidebar li.collapsArchPost {
     text-indent:-1em;
      list-style-type:none;
     margin:0 0 0 1em;}
#sidebar li.collapsArchPost:before {content: '\00BB \00A0' !important;} 
#sidebar li.collapsArch .sym {
       font-size:1.2em;
       font-family:Monaco, 'Andale Mono', 'FreeMono', 'Courier new', 'Courier', monospace;
       margin:2px 5px 0px 0; 
       line-height:.8em;
       padding:0;
       /* uncomment to put a box around +/-
       border:1px solid;
       height:.9em;
       display:inline-block;
       vertical-align:baseline;
       */
      }                                                </style>
<style type="text/css">
					.site-title a,
			.site-description {
				color: #dd0202;
			}
				</style>
</head>
<body class="post-template-default single single-post postid-549467 single-format-standard no-sidebar right-sidebar">
<div id="page" class="site">
<a class="skip-link screen-reader-text" href="#content">Skip to content</a>
<header id="masthead" class="site-header">
<div class="twp-topbar clearfix">
<div class="twp-topbar-content-left twp-float-left clearfix">
<div class="twp-current-date twp-float-left">
Thursday, Aug 5, 2021 </div>
<div class="twp-title twp-title-with-arrow twp-title-primary twp-float-left">
Breaking News </div>
<div class="twp-breaking-news-section">
<div class="twp-ticket-pin-slider clearfix" data-slick='{"rtl": false}'>
<div class="twp-ticket-pin">
<div class="twp-image-section">
<a href="https://trinidadtribune.com/griffith-makes-fresh-appeal-for-passage-of-bail-amendment-bill-4/" class="data-bg d-block" data-background=""></a>
</div>
<div class="twp-articles-title">
<a href="https://trinidadtribune.com/griffith-makes-fresh-appeal-for-passage-of-bail-amendment-bill-4/">Griffith makes fresh appeal for passage of Bail Amendment Bill</a>
</div>
</div>
<div class="twp-ticket-pin">
<div class="twp-image-section">
<a href="https://trinidadtribune.com/griffith-makes-fresh-appeal-for-passage-of-bail-amendment-bill/" class="data-bg d-block" data-background=""></a>
</div>
<div class="twp-articles-title">
<a href="https://trinidadtribune.com/griffith-makes-fresh-appeal-for-passage-of-bail-amendment-bill/">Griffith makes fresh appeal for passage of Bail Amendment Bill</a>
</div>
</div>
<div class="twp-ticket-pin">
<div class="twp-image-section">
<a href="https://trinidadtribune.com/sadness-for-his-student-criminologist-wants-errant-cops-disciplined-4/" class="data-bg d-block" data-background=""></a>
</div>
<div class="twp-articles-title">
<a href="https://trinidadtribune.com/sadness-for-his-student-criminologist-wants-errant-cops-disciplined-4/">Sadness for his student: Criminologist wants errant cops disciplined</a>
</div>
</div>
<div class="twp-ticket-pin">
<div class="twp-image-section">
<a href="https://trinidadtribune.com/griffith-makes-fresh-appeal-for-passage-of-bail-amendment-bill-2/" class="data-bg d-block" data-background=""></a>
</div>
<div class="twp-articles-title">
<a href="https://trinidadtribune.com/griffith-makes-fresh-appeal-for-passage-of-bail-amendment-bill-2/">Griffith makes fresh appeal for passage of Bail Amendment Bill</a>
</div>
</div>
<div class="twp-ticket-pin">
<div class="twp-image-section">
<a href="https://trinidadtribune.com/griffith-makes-fresh-appeal-for-passage-of-bail-amendment-bill-3/" class="data-bg d-block" data-background=""></a>
</div>
<div class="twp-articles-title">
<a href="https://trinidadtribune.com/griffith-makes-fresh-appeal-for-passage-of-bail-amendment-bill-3/">Griffith makes fresh appeal for passage of Bail Amendment Bill</a>
</div>
</div>
<div class="twp-ticket-pin">
<div class="twp-image-section">
<a href="https://trinidadtribune.com/sadness-for-his-student-criminologist-wants-errant-cops-disciplined-2/" class="data-bg d-block" data-background=""></a>
</div>
<div class="twp-articles-title">
<a href="https://trinidadtribune.com/sadness-for-his-student-criminologist-wants-errant-cops-disciplined-2/">Sadness for his student: Criminologist wants errant cops disciplined</a>
</div>
</div>
<div class="twp-ticket-pin">
<div class="twp-image-section">
<a href="https://trinidadtribune.com/sadness-for-his-student-criminologist-wants-errant-cops-disciplined-3/" class="data-bg d-block" data-background=""></a>
</div>
<div class="twp-articles-title">
<a href="https://trinidadtribune.com/sadness-for-his-student-criminologist-wants-errant-cops-disciplined-3/">Sadness for his student: Criminologist wants errant cops disciplined</a>
</div>
</div>
<div class="twp-ticket-pin">
<div class="twp-image-section">
<a href="https://trinidadtribune.com/after-teen-electrocuted-stealing-copper-friends-home-set-on-fire-4/" class="data-bg d-block" data-background=""></a>
</div>
<div class="twp-articles-title">
<a href="https://trinidadtribune.com/after-teen-electrocuted-stealing-copper-friends-home-set-on-fire-4/">After teen electrocuted stealing copper, friend’s home set on fire</a>
</div>
</div>
<div class="twp-ticket-pin">
<div class="twp-image-section">
<a href="https://trinidadtribune.com/sadness-for-his-student-criminologist-wants-errant-cops-disciplined/" class="data-bg d-block" data-background=""></a>
</div>
<div class="twp-articles-title">
<a href="https://trinidadtribune.com/sadness-for-his-student-criminologist-wants-errant-cops-disciplined/">Sadness for his student: Criminologist wants errant cops disciplined</a>
</div>
</div>
<div class="twp-ticket-pin">
<div class="twp-image-section">
<a href="https://trinidadtribune.com/daughter-mom-and-friend-admit-to-murder-of-abusive-man-3/" class="data-bg d-block" data-background=""></a>
</div>
<div class="twp-articles-title">
<a href="https://trinidadtribune.com/daughter-mom-and-friend-admit-to-murder-of-abusive-man-3/">Daughter, mom and friend admit to murder of abusive man</a>
</div>
</div>
<div class="twp-ticket-pin">
<div class="twp-image-section">
<a href="https://trinidadtribune.com/after-teen-electrocuted-stealing-copper-friends-home-set-on-fire/" class="data-bg d-block" data-background=""></a>
</div>
<div class="twp-articles-title">
<a href="https://trinidadtribune.com/after-teen-electrocuted-stealing-copper-friends-home-set-on-fire/">After teen electrocuted stealing copper, friend’s home set on fire</a>
</div>
</div>
<div class="twp-ticket-pin">
<div class="twp-image-section">
<a href="https://trinidadtribune.com/after-teen-electrocuted-stealing-copper-friends-home-set-on-fire-2/" class="data-bg d-block" data-background=""></a>
</div>
<div class="twp-articles-title">
<a href="https://trinidadtribune.com/after-teen-electrocuted-stealing-copper-friends-home-set-on-fire-2/">After teen electrocuted stealing copper, friend’s home set on fire</a>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="twp-site-branding data-bg " data-background="">
<div class="container">
<div class="twp-wrapper">
<div class="twp-logo">
<div class="twp-image-wrapper"></div>
<p class="site-title"><a href="https://trinidadtribune.com/" rel="home">Trinidad News</a></p>
<p class="site-description">Daily News from Trinidad and Tobago</p>
</div>
</div>
</div>
</div>
<nav id="site-navigation" class="twp-navigation">
<div class="twp-nav-menu-section">
<div class="container">
<div class="twp-row twp-wrapper">
<div class="twp-menu-section desktop twp-d-flex">
<div class="twp-nav-menu"><ul id="primary-menu" class="twp-nav-menu"><li class="brand-home"><a title="Home" href="https://trinidadtribune.com"><span class='fa fa-home'></span></a></li><li id="menu-item-127129" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-127129"><a href="http://www.trinidadtribune.com/">Home</a></li>
<li id="menu-item-127602" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-127602"><a href="https://trinidadtribune.com/category/latest-news/">Latest News</a></li>
<li id="menu-item-127598" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-127598"><a href="http://www.trinidadtribune.com/category/caribbean-news/">Caribbean News</a></li>
<li id="menu-item-127599" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-127599"><a href="http://www.trinidadtribune.com/category/pr-news/">PR News</a></li>
</ul></div> <div class="twp-menu-icon-section">
<div class="twp-menu-icon twp-menu-icon-white" id="twp-menu-icon">
<span></span>
</div>
</div>
</div>
<div class="twp-site-features">

<div class="theme-mode header-theme-mode"></div>
<div class="twp-trending" id="nav-latest-news">
<i class="fa fa-flash"></i>
</div>
<div class="twp-search" id="search">
<i class="fa fa-search"></i>
</div>
</div>
</div>
</div>
<div class="twp-progress-bar" id="progressbar">
</div>
</div>
<div class="twp-search-field-section" id="search-field">
<div class="container">
<div class="twp-search-field-wrapper">
<div class="twp-search-field">
<form role="search" method="get" class="search-form" action="https://trinidadtribune.com/">
<label>
<span class="screen-reader-text">Search for:</span>
<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
</label>
<input type="submit" class="search-submit" value="Search" />
</form> </div>
<div class="twp-close-icon-section">
<span class="twp-close-icon" id="search-close">
<span></span>
<span></span>
</span>
</div>
</div>
</div>
</div>

<div class="twp-article-list" id="nav-latest-news-field">
<div class="container">
<header class="twp-article-header">
<h3>
Trending Now </h3>
<div class="twp-close-icon-section">
<span class="twp-close-icon" id="latest-news-close">
<span></span>
<span></span>
</span>
</div>
</header>
<div class="twp-row">

<div class="twp-col-4 twp-article-border">
<div class="twp-article">
<div class="twp-units">
1 </div>
<div class="twp-description">
<h4><a href="https://trinidadtribune.com/lawsuit-filed-to-stop-deportation-of-migrant-women-and-children/">Lawsuit filed to stop deportation of migrant women and children</a></h4>
<div class="twp-author-meta">
<span class="twp-post-date">
<i class="fa fa-clock-o"></i>
8 months ago </span>
</div>
</div>
</div>
</div>

<div class="twp-col-4 twp-article-border">
<div class="twp-article">
<div class="twp-units">
2 </div>
<div class="twp-description">
<h4><a href="https://trinidadtribune.com/live-cricket-score-pakistan-vs-sri-lanka-1st-odi-dubai-cricbuzz/">Live Cricket Score: Pakistan vs Sri Lanka, 1st ODI, Dubai &#8211; Cricbuzz</a></h4>
<div class="twp-author-meta">
<span class="twp-post-date">
<i class="fa fa-clock-o"></i>
4 years ago </span>
</div>
</div>
</div>
</div>

<div class="twp-col-4 twp-article-border">
<div class="twp-article">
<div class="twp-units">
3 </div>
<div class="twp-description">
<h4><a href="https://trinidadtribune.com/man-charged-with-wounding-after-fight-3/">Man charged with wounding after fight</a></h4>
<div class="twp-author-meta">
<span class="twp-post-date">
<i class="fa fa-clock-o"></i>
8 months ago </span>
</div>
</div>
</div>
</div>

<div class="twp-col-4 twp-article-border">
<div class="twp-article">
<div class="twp-units">
4 </div>
<div class="twp-description">
<h4><a href="https://trinidadtribune.com/disruption-to-water-service-in-malick-and-environs-2/">Disruption to water service in Malick and environs</a></h4>
<div class="twp-author-meta">
<span class="twp-post-date">
<i class="fa fa-clock-o"></i>
9 months ago </span>
</div>
</div>
</div>
</div>

<div class="twp-col-4 twp-article-border">
<div class="twp-article">
<div class="twp-units">
5 </div>
<div class="twp-description">
<h4><a href="https://trinidadtribune.com/updated-wallace-to-appeal-fifa-removal-of-ttfa-board-4/">[UPDATED] Wallace to appeal FIFA removal of TTFA board</a></h4>
<div class="twp-author-meta">
<span class="twp-post-date">
<i class="fa fa-clock-o"></i>
1 year ago </span>
</div>
</div>
</div>
</div>

<div class="twp-col-4 twp-article-border">
<div class="twp-article">
<div class="twp-units">
6 </div>
<div class="twp-description">
<h4><a href="https://trinidadtribune.com/cities-in-culture-how-todays-peckham-compares-with-only-fools-and-horses-the-guardian/">Cities in culture: how today&#8217;s Peckham compares with Only Fools and Horses &#8211; The Guardian</a></h4>
<div class="twp-author-meta">
<span class="twp-post-date">
<i class="fa fa-clock-o"></i>
7 years ago </span>
 </div>
</div>
</div>
</div>

<div class="twp-col-4 twp-article-border">
<div class="twp-article">
<div class="twp-units">
7 </div>
<div class="twp-description">
<h4><a href="https://trinidadtribune.com/ball-state-soccer-plays-host-to-puerto-rico-national-team-ball-state-daily/">Ball State soccer plays host to Puerto Rico national team &#8211; Ball State Daily</a></h4>
<div class="twp-author-meta">
<span class="twp-post-date">
<i class="fa fa-clock-o"></i>
4 years ago </span>
</div>
</div>
</div>
</div>

<div class="twp-col-4 twp-article-border">
<div class="twp-article">
<div class="twp-units">
8 </div>
<div class="twp-description">
<h4><a href="https://trinidadtribune.com/sunil-narine-named-emerging-player-of-the-year-%e2%80%93-cricket-news-update-%e2%80%93-bettor-com-blog/">Sunil Narine named Emerging Player of the Year – Cricket News Update – bettor.com (blog)</a></h4>
<div class="twp-author-meta">
<span class="twp-post-date">
<i class="fa fa-clock-o"></i>
9 years ago </span>
</div>
</div>
</div>
</div>

<div class="twp-col-4 twp-article-border">
<div class="twp-article">
<div class="twp-units">
9 </div>
<div class="twp-description">
<h4><a href="https://trinidadtribune.com/missing-shannon-turned-23-yesterday-2/">Missing Shannon turned 23 yesterday</a></h4>
<div class="twp-author-meta">
<span class="twp-post-date">
<i class="fa fa-clock-o"></i>
4 years ago </span>
</div>
</div>
</div>
</div>

<div class="twp-col-4 twp-article-border">
<div class="twp-article">
<div class="twp-units">
10 </div>
<div class="twp-description">
<h4><a href="https://trinidadtribune.com/tourism-sector-untapped-fortune-proper-marketing-needed-newsday-trinidad-news/">Tourism Sector untapped fortune Proper Marketing needed &#8211; Newsday &#8211; Trinidad News</a></h4>
<div class="twp-author-meta">
<span class="twp-post-date">
<i class="fa fa-clock-o"></i>
5 years ago </span>
</div>
</div>
</div>
</div>

<div class="twp-col-4 twp-article-border">
<div class="twp-article">
<div class="twp-units">
11 </div>
<div class="twp-description">
<h4><a href="https://trinidadtribune.com/ttcb-welcome-new-ceo-%e2%80%93-trinidad-tobago-express/">TTCB welcome new CEO – Trinidad &amp; Tobago Express</a></h4>
<div class="twp-author-meta">
<span class="twp-post-date">
<i class="fa fa-clock-o"></i>
9 years ago </span>
</div>
</div>
</div>
</div>

<div class="twp-col-4 twp-article-border">
<div class="twp-article">
<div class="twp-units">
12 </div>
<div class="twp-description">
<h4><a href="https://trinidadtribune.com/kamla-who-benefits-from-motion-to-exempt-custom-duties-2/">Kamla: Who benefits from motion to exempt Custom duties?</a></h4>
<div class="twp-author-meta">
<span class="twp-post-date">
<i class="fa fa-clock-o"></i>
8 months ago </span>
</div>
</div>
</div>
</div>
</div>
</div>
</div>

</nav>
</header>
<div class="twp-mobile-menu">
<div class="twp-mobile-close-icon">
<span class="twp-close-icon twp-close-icon-sm twp-close-icon-white twp-rotate-90" id="twp-mobile-close">
<span></span>
<span></span>
</span>
</div>
</div>
<div class="twp-body-overlay" id="overlay"></div>

<div class="twp-breadcrumbs">
<div class="container">
<div role="navigation" aria-label="Breadcrumbs" class="breadcrumb-trail breadcrumbs" itemprop="breadcrumb"><ul class="trail-items" itemscope itemtype="http://schema.org/BreadcrumbList"><meta name="numberOfItems" content="3" /><meta name="itemListOrder" content="Ascending" /><li itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem" class="trail-item trail-begin"><a href="https://trinidadtribune.com/" rel="home" itemprop="item"><span itemprop="name">Home</span></a><meta itemprop="position" content="1" /></li><li itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem" class="trail-item"><a href="https://trinidadtribune.com/category/pr-news/" itemprop="item"><span itemprop="name">PR News</span></a><meta itemprop="position" content="2" /></li><li itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem" class="trail-item trail-end"><span itemprop="item"><span itemprop="name">Michelin Star Chef, Antonio Mellino Heads Quattro Passi at The Cliff</span></span><meta itemprop="position" content="3" /></li></ul></div> </div>
</div>

<div id="content" class="site-content">
<div id="primary" class="content-area">
<main id="main" class="site-main">
<article id="post-549467" class="twp-article-post post-549467 post type-post status-publish format-standard hentry category-pr-news">
<header class="entry-header">
<div class="twp-categories-with-bg twp-categories-with-bg-primary">
<ul class="cat-links"><li>
<a href="https://trinidadtribune.com/category/pr-news/" alt="View all posts in PR News">
PR News
</a>
</li></ul> </div>
<h1 class="entry-title">
<a href="" rel="bookmark">
Michelin Star Chef, Antonio Mellino Heads Quattro Passi at The Cliff </a>
</h1>
<div class="twp-author-meta">
<a href="https://trinidadtribune.com/author/admin/">
<span class="twp-author-image"><img src="https://secure.gravatar.com/avatar/b563f2bedccc65bc94691e79a825a968?s=150&#038;d=mm&#038;r=g"></span>
<span class="twp-author-caption">admin</span>
</a>
<span class="twp-post-date">
<i class="fa fa-clock-o"></i>
1 week ago </span>
</div>
</header>
<div class="entry-content">
<p>The flavours of Amalfi and Napoli arrive in Barbados</p>
<p>BRIDGETOWN, Barbados, July 27, 2021 /PRNewswire-HISPANIC PR WIRE/ &#8212; Antonio Mellino, the Executive chef at Quattro Passi will open QP Bistro the 22, October 2021 and Quattro Passi at The Cliff at the end of November. Quattro Passi in Nerano, Italy, is acclaimed as the best on the Amalfi Coast with two Michelin stars. Bringing the flavours of the Campania region, Napoli and Southern Italy to Barbados, it will offer signature dishes with the finest, fresh ingredients.</p>
<p>Antonio and his team, including his son Raffaele aspire to have the finest restaurant in the world. Located on the former renowned Cliff restaurant site, the team has paid great care with the site&#8217;s huge and amazing refurbishment with the most stunning views of the blue Caribbean Sea.</p>
<p>Mellino&#8217;s food philosophy is innovative but respects tradition and seasonality. This approach to his signature dishes &#8211; such as one that combines linguini with zucchini and zucchini flowers with basil and black pepper perfected over 10 years &#8211; earned Quattro Passi its Michelin stars. Mellino has cooked for Kings, presidents, elite artists, athletes and farmers all over the world. Mellino is excited to source fresh ingredients in Barbados from local and Caribbean farmers. The team will also be importing the best ingredients, shellfish from Italy, beef from the UK; the champagne will be imported insulated and chilled, so the temperature is always correct. &#8220;I absolutely love the energy of Barbados, and I am telling all of my regular clientele to meet me there. I couldn&#8217;t be more excited to open this unbelievable Quattro Passi in Barbados. We will make this the best restaurant in the world, on the best island, Barbados.&#8221;</p>
<p>To reflect the food philosophy the interior design plans are an exquisite mix of Moroccan and Italian decor. Quattro Passi will feature a cigar bar, a lounge, private dining areas, all with tables overlooking the ocean. Next door to the fine dining of Quattro Passi will be QP Bistro. This will have an all-day, 7:30 am-2:00 am, bistro menu, a large Italian pizza oven, homemade soft-serve ice cream and young, vibrant energy.</p>
<p>Quarto Passi and QP Bistro are owned by Michael Kent, a resident of Barbados. He also owns the Tides Restaurant in Barbados. Born on a farm in Cornwall, England, he is relentless in working with the best local people wherever he is. He loves how calm and friendly Barbadians are. He believes for the best restaurant one needs, in order of importance, the best people, the best local produce, the best facilities and the best location, Quattro Passi has it all.</p>
<p>Kent has hired Élan Mottley, who recently returned to Barbados from Sydney, Australia as director of all restaurants. An experienced marketer in gourmet products and an attorney by training, Kent says, &#8220;Élan has so much energy and an amazing attitude.&#8221;</p>
<p>Quattro Passi is taking reservations for the winter season at 1-246-432-1922 and QP Bistro at 1-246-432-0797</p>
</div>
</article>
<div class="twp-single-next-post">
<div class="twp-next-post">
<a href="https://trinidadtribune.com/ibex-takes-firm-hold-of-bpo-industry-leadership-in-jamaica-opens-its-fifth-site-in-five-years/">
Next Post<i class="fa fa-chevron-right"></i>
</a>
</div>
<div class="twp-categories-with-bg twp-categories-with-bg-primary "><ul class="cat-links"><li>
<a href="https://trinidadtribune.com/category/pr-news/" alt="View all posts in PR News">
PR News
</a>
</li></ul></div>
<h2><a href="https://trinidadtribune.com/ibex-takes-firm-hold-of-bpo-industry-leadership-in-jamaica-opens-its-fifth-site-in-five-years/">ibex Takes Firm Hold of BPO Industry Leadership in Jamaica - Opens its Fifth Site in Five Years</a></h2>
<div class="twp-author-meta"><span class="twp-post-date"><i class="fa fa-clock-o"></i>Mon Aug 2 , 2021</span></div>
<div class="twp-caption">CaribPR Wire, WASHINGTON, Aug. 02, 2021: ibex (NASDAQ: IBEX), a global leader in business process outsourcing (BPO) and end-to-end customer engagement technology solutions, today announced the opening of its new Campus location in the Sunshine City area of Portmore, Jamaica. The new facility will create 1,300 digitally-enabled jobs, bringing the [&hellip;]</div>
</div>
<div class="twp-related-post-section">
<div class="container">
<h2 class="twp-title twp-title-with-dashed">You May Like</h2>
<ul class="twp-related-post-list">
<li class="twp-related-post twp-d-flex">
<div class="twp-image-section twp-image-hover">
<a href="https://trinidadtribune.com/cable-wireless-reports-preliminary-q3-2017-results-2/" class="data-bg" data-background=""></a>
</div>
<div class="twp-desc twp-bg-light-gray">
<div class="twp-categories-with-bg twp-categories-with-bg-primary">
<ul class="cat-links"><li>
<a href="https://trinidadtribune.com/category/pr-news/" alt="View all posts in PR News">
PR News
</a>
</li></ul> </div>
<h3><a href="https://trinidadtribune.com/cable-wireless-reports-preliminary-q3-2017-results-2/">Cable &amp; Wireless Reports Preliminary Q3 2017 Results</a></h3>
<div class="twp-social-share-section">
<div class="twp-author-meta m-0">
<a href="https://trinidadtribune.com/author/admin/">
<span class="twp-author-image"><img src="https://secure.gravatar.com/avatar/b563f2bedccc65bc94691e79a825a968?s=150&#038;d=mm&#038;r=g"></span>
<span class="twp-author-caption">admin</span>
</a>
<span class="twp-post-date">
<i class="fa fa-clock-o"></i>
4 years ago </span>
</div>
</div>
</div>
</li>
<li class="twp-related-post twp-d-flex">
<div class="twp-image-section twp-image-hover">
<a href="https://trinidadtribune.com/cable-wireless-charitable-foundation-makes-donation-to-community-impact-organization-curaao-cares-3/" class="data-bg" data-background=""></a>
</div>
<div class="twp-desc twp-bg-light-gray">
<div class="twp-categories-with-bg twp-categories-with-bg-primary">
<ul class="cat-links"><li>
<a href="https://trinidadtribune.com/category/pr-news/" alt="View all posts in PR News">
PR News
</a>
</li></ul> </div>
<h3><a href="https://trinidadtribune.com/cable-wireless-charitable-foundation-makes-donation-to-community-impact-organization-curaao-cares-3/">Cable &amp; Wireless Charitable Foundation makes donation to community impact organization Cura&ccedil;ao Cares</a></h3>
<div class="twp-social-share-section">
<div class="twp-author-meta m-0">
<a href="https://trinidadtribune.com/author/admin/">
<span class="twp-author-image"><img src="https://secure.gravatar.com/avatar/b563f2bedccc65bc94691e79a825a968?s=150&#038;d=mm&#038;r=g"></span>
<span class="twp-author-caption">admin</span>
</a>
<span class="twp-post-date">
<i class="fa fa-clock-o"></i>
3 years ago </span>
</div>
</div>
</div>
</li>
<li class="twp-related-post twp-d-flex">
<div class="twp-image-section twp-image-hover">
<a href="https://trinidadtribune.com/mainstream-us-media-with-photo-3/" class="data-bg" data-background=""></a>
</div>
<div class="twp-desc twp-bg-light-gray">
<div class="twp-categories-with-bg twp-categories-with-bg-primary">
<ul class="cat-links"><li>
<a href="https://trinidadtribune.com/category/pr-news/" alt="View all posts in PR News">
PR News
</a>
</li></ul> </div>
<h3><a href="https://trinidadtribune.com/mainstream-us-media-with-photo-3/">Mainstream US media With photo</a></h3>
<div class="twp-social-share-section">
<div class="twp-author-meta m-0">
<a href="https://trinidadtribune.com/author/admin/">
<span class="twp-author-image"><img src="https://secure.gravatar.com/avatar/b563f2bedccc65bc94691e79a825a968?s=150&#038;d=mm&#038;r=g"></span>
<span class="twp-author-caption">admin</span>
</a>
<span class="twp-post-date">
<i class="fa fa-clock-o"></i>
8 years ago </span>
</div>
</div>
</div>
</li>
<li class="twp-related-post twp-d-flex">
<div class="twp-image-section twp-image-hover">
<a href="https://trinidadtribune.com/the-definitive-caribbean-investment-forum-returns-to-new-york-city-this-june/" class="data-bg" data-background=""></a>
</div>
<div class="twp-desc twp-bg-light-gray">
<div class="twp-categories-with-bg twp-categories-with-bg-primary">
<ul class="cat-links"><li>
<a href="https://trinidadtribune.com/category/pr-news/" alt="View all posts in PR News">
PR News
</a>
</li></ul> </div>
<h3><a href="https://trinidadtribune.com/the-definitive-caribbean-investment-forum-returns-to-new-york-city-this-june/">The Definitive Caribbean Investment Forum Returns To New York City This June</a></h3>
<div class="twp-social-share-section">
<div class="twp-author-meta m-0">
<a href="https://trinidadtribune.com/author/admin/">
<span class="twp-author-image"><img src="https://secure.gravatar.com/avatar/b563f2bedccc65bc94691e79a825a968?s=150&#038;d=mm&#038;r=g"></span>
<span class="twp-author-caption">admin</span>
</a>
<span class="twp-post-date">
<i class="fa fa-clock-o"></i>
8 years ago </span>
</div>
</div>
</div>
</li>
<li class="twp-related-post twp-d-flex">
<div class="twp-image-section twp-image-hover">
<a href="https://trinidadtribune.com/new-uae-t20-league-promises-to-be-a-unique-development-platform-for-regional-and-international-players-alike-3/" class="data-bg" data-background=""></a>
</div>
<div class="twp-desc twp-bg-light-gray">
<div class="twp-categories-with-bg twp-categories-with-bg-primary">
<ul class="cat-links"><li>
<a href="https://trinidadtribune.com/category/pr-news/" alt="View all posts in PR News">
PR News
</a>
</li></ul> </div>
<h3><a href="https://trinidadtribune.com/new-uae-t20-league-promises-to-be-a-unique-development-platform-for-regional-and-international-players-alike-3/">New UAE T20 League Promises to Be a Unique Development Platform for Regional and International Players Alike</a></h3>
<div class="twp-social-share-section">
<div class="twp-author-meta m-0">
<a href="https://trinidadtribune.com/author/admin/">
<span class="twp-author-image"><img src="https://secure.gravatar.com/avatar/b563f2bedccc65bc94691e79a825a968?s=150&#038;d=mm&#038;r=g"></span>
<span class="twp-author-caption">admin</span>
</a>
<span class="twp-post-date">
<i class="fa fa-clock-o"></i>
3 years ago </span>
</div>
</div>
</div>
</li>
<li class="twp-related-post twp-d-flex">
<div class="twp-image-section twp-image-hover">
<a href="https://trinidadtribune.com/blue-diamond-resorts-announces-that-paradise-is-open-with-official-hotel-reopening-dates-5/" class="data-bg" data-background=""></a>
</div>
<div class="twp-desc twp-bg-light-gray">
<div class="twp-categories-with-bg twp-categories-with-bg-primary">
<ul class="cat-links"><li>
<a href="https://trinidadtribune.com/category/pr-news/" alt="View all posts in PR News">
PR News
</a>
</li></ul> </div>
<h3><a href="https://trinidadtribune.com/blue-diamond-resorts-announces-that-paradise-is-open-with-official-hotel-reopening-dates-5/">Blue Diamond Resorts announces that “Paradise is Open” with official hotel reopening dates</a></h3>
<div class="twp-social-share-section">
<div class="twp-author-meta m-0">
<a href="https://trinidadtribune.com/author/admin/">
<span class="twp-author-image"><img src="https://secure.gravatar.com/avatar/b563f2bedccc65bc94691e79a825a968?s=150&#038;d=mm&#038;r=g"></span>
<span class="twp-author-caption">admin</span>
</a>
<span class="twp-post-date">
<i class="fa fa-clock-o"></i>
11 months ago </span>
</div>
</div>
</div>
</li>
</ul>
</div>
</div>
</main>
</div>
</div>


<div class="twp-footer-widget-section">
<div class="container  twp-footer-border">
<div class="twp-row">
</div>
</div>
</div>
<div class="twp-footer-social-section">
<div class="container">
<div class="twp-footer-social">
</div>
</div>
</div>
<footer id="colophon" class="site-footer">
<div class="container">
<div class="site-info">
WordPress Theme: Seek by <a href="https://themeinwp.com" target="_blank" rel="designer">ThemeInWP </a> </div>
</div>
</footer>
<div class="twp-scroll-top" id="scroll-top">
<span><i class="fa fa-chevron-up"></i></span>
</div>
</div>
<script type='text/javascript' src='https://trinidadtribune.com/wp-content/themes/seek/js/navigation.js?ver=20151215'></script>
<script type='text/javascript' src='https://trinidadtribune.com/wp-content/themes/seek/assets/libraries/slick/js/slick.min.js?ver=5.4.6'></script>
<script type='text/javascript' src='https://trinidadtribune.com/wp-content/themes/seek/assets/libraries/magnific/js/jquery.magnific-popup.min.js?ver=5.4.6'></script>
<script type='text/javascript' src='https://trinidadtribune.com/wp-content/themes/seek/assets/libraries/color-switcher/color-switcher.js?ver=5.4.6'></script>
<script type='text/javascript' src='https://trinidadtribune.com/wp-content/themes/seek/js/skip-link-focus-fix.js?ver=20151215'></script>
<script type='text/javascript' src='https://trinidadtribune.com/wp-content/themes/seek/assets/libraries/theiaStickySidebar/theia-sticky-sidebar.min.js?ver=5.4.6'></script>
<script type='text/javascript' src='https://trinidadtribune.com/wp-content/themes/seek/assets/twp/js/main.js?ver=5.4.6'></script>
<script type='text/javascript' src='https://trinidadtribune.com/wp-includes/js/wp-embed.min.js?ver=5.4.6'></script>
</body>
</html>
